Centos下Yum安装PHP5.6


最近用laravel 5.1 要求php环境为5.6  yum安装默认的是5.4 又懒得编译安装  的可以看下

  1. 检查是否安装了已有的php包

    yum list installed | grep php
  2. 如果安装了,卸载掉之前的php版本

    yum remove php-mysql php-gd libjpeg* php-imap php-ldap php-odbc php-pear php-xml php-xmlrpc php-mbstring php-mcrypt php-bcmath php-mhash libmcrypt libmcrypt-devel php-fpm


  3. 添加包

    rpm -Uvh https://mirror.webtatic.com/yum/el7/epel-release.rpm
    rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

  4. 运行安装

    yum install php56w php56w-mysql php56w-gd libjpeg* php56w-imap php56w-ldap php56w-odbc php56w-pear php56w-xml php56w-xmlrpc php56w-mbstring php56w-mcrypt php56w-bcmath php56w-mhash libmcrypt libmcrypt-devel php56w-fpm



  Linux , PHP
 

音乐的名字啊名字
  • 00:00